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Welcome to Extensis™ PhotoAnimator™! PhotoAnimator is an
exciting, full-fledged yet affordable animation package that will
change forever the way you create and work with Web
animations. 

While other GIF animation software packages are simple frame
compilers, PhotoAnimator is a professional animation sequencer.
No more carving effects and cropping frames by hand—with
PhotoAnimator you can do it painlessly! Simply import the raw
elements designed in Photoshop®, then scale, rotate, flip, move,
repeat, or invert each image right in PhotoAnimator. Create
instant transition effects such as fade, wipe, merge, and barn door.
Specify on-the-fly over how many frames your imaging or transi-
tion effects will occur. And because file size and color palettes are
optimized automatically, you can be sure that PhotoAnimator will
produce the smallest file size possible.

No matter what your skill level, PhotoAnimator will dramatically
reduce the time and effort needed to create high-quality GIF ani-
mations—and let you have fun while you’re doing it!

System and Software Requirements

To install and use PhotoAnimator, you will need the following:

M a c i n t o s h :
•   Power Macintosh® or equivalent
•   Mac OS® System 7.5 or higher 
• 8MB free hard disk space for PhotoAnimat o r, t h e

P h o t o A n i m ator User Guide PDF, and Tu t o rial Sample Fi l e s

Wi n d ow s :
•   PC with Pentium processor or faster 
•   Microsoft® Windows 95® or Windows NT® 4.0
• 8MB free hard disk space for PhotoAnimat o r, t h e

P h o t o A n i m ator User Guide PDF, and Tu t o rial Sample Fi l e s

Installation

By default, the installer will place PhotoAnimator, the User
Guide, and the Tutorial Sample Files in the following locations:

M a c i n t o s h :
• Ap p l i c ation and User Guide—Hard disk: P h o t o A n i m at o r™ 1 . 0
• Tutorial Sample Files—Hard disk: PhotoAnimator™ 1.0:

Tutorials

Introducing PhotoAnimator
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Wi n d ow s :
• Application and User Guide—C:\Program Files\Extensis\

PhotoAnimator™ 1.0
• Tutorial Sample Files—C:\Program Files\Extensis\

PhotoAnimator™ 1.0\Tutorials

Registration

You can quick ly register your copy of PhotoAnimator on-line
at the Extensis Web site: h t t p : / / w w w. extensis.com/PA_Reg. 
If you do not have internet access, call Extensis Customer 
Service at (503) 274-2020 to register by phone.

If you choose not to personalize your copy, PhotoAnimator will
run in a demonstration mode that allows you to use the product
for 30 days. 

Technical Support

For questions regarding Extensis PhotoAnimator, please first
refer to this manual, which describes program features and basic
operations. We invite you to visit our PhotoAnimator page on the
Extensis website (www.extensis.com) for frequently asked
questions and trouble-shooting tips.

If you have a question wh i ch is not add ressed in this manual or
on the Extensis web s i t e, Te chnical Support is ava i l able by phone
at (503) 274-7030, M o n d ay through Fri d ay, 8:00 a.m. to 5:00 p.m.
Pa c i fic time. When calling for technical support, please be at your
computer and have the following information available: your
Extensis PhotoAnimator registration number, your computer con-
figuration, and your question or a description of the difficulty
you’re experiencing—what specifically occurs and when. Take
note of any displayed error numbers or messages and any other
information you think may be relevant.

Suggestions

We’d love to hear your comments about Extensis PhotoAnimator!
For your convenience, a suggestion sheet is included at the end of
this manual. Please fax, mail, or e-mail your comments and
suggestions to Extensis.

Tip

We can also be reached by:

Fax: (503) 274-0530

E-mail: support@extensis.com

I n t e r n e t :
h t t p : / / w w w. e x t e n s i s . c o m / s u p p o r t

http://www.extensis.com/support
http://www.extensis.com/PA_Reg
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Extensis PhotoAnimator helps you create stunning and exciting
animations with almost no effo rt. You start with raw animation
elements saved either in native Photoshop format (.psd), or as GIF
images (.gif), then use PhotoAnimator’s intuitive tools to add spe-
cial effects to create the animation. Or import existing animations
and use PhotoAnimator to enhance them. No matter what images
you start with, just follow these few step s :

1) Open PhotoAnimator and specify a display size for the 
animation.

2 ) I m p o rt raw animation element files (.psd, . gi f ) .
3 ) Apply special effects and play back your animations as you

design them. Loop your sequences or play them frame by
frame—you  can even use multiple windows to compare and
contrast effects—until you achieve just the effect you want.

4 ) When the design is complete, ex p o rt out as a GIF A n i m at i o n .

U n l i ke fra m e - by - f rame animation progra m s , P h o t o A n i m at o r
a l l ows you to use laye rs and to ap p ly effects to re s i ze able cells.
You can animate each layer indep e n d e n t ly, and combine them
h owever you like. With PhotoAnimator you have the freedom to
edit your animations to your heart ’s content, p rev i ewing as yo u
c re ate them, rather than being limited to viewing the results after
all the frames have been cre at e d. 

E a ch animation layer can have multiple cells, and each cell can
h ave its own effect applied to it. PhotoAnimator automat i c a l ly
ge n e rates the specified effect over a ra n ge of cell frames. You can
e a s i ly expand or contract the number of frames in a cell, a n d
P h o t o A n i m ator will automat i c a l ly re c a l c u l ate the effect for the
e n t i re cell. 

By combining PhotoAnimat o r ’s special Image, M a s k , Tra n s i t i o n
and Filter effects like scale, ro t at e, s p i n , fa d e, w i p e, b a rn door,
gradient mask, and inve rt , the possibilities for striking and 
p ro fessional-looking animations are virt u a l ly endless.

We think yo u ’ll find Extensis PhotoAnimator a nat u ral tool fo r
Web animat i o n s , and an inva l u able tool in your cre at ive arsenal. If
you have questions, c o m m e n t s , or sugge s t i o n s , please contact us at
our Web site, h t t p : / / w w w. ex t e n s i s . c o m , or at the location listed on
the inside front cover of this User Guide. 

Gather Raw Elements

Instant Animation!

Apply Unlimited Special Effects

PhotoAnimator Overview
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The PhotoAnimator window is the primary window, containing
three separate panes: the Layers Pane, the Preview Pane, and the
Filmstrip Pane.

Layers Pane: Displays all the layers available for the animation.
Each layer can contain from one to 300 animation frames. This
pane functions similar to the Photoshop Layers palette, allowing
you to create, name, hide, delete, and reposition layers.

Preview Pane: Displays a preview of the animation. This preview
is always available and can be viewed from any dialog box as you
work with animation effects.

Filmstrip Pane: Displays the cells and frames that make up the
animation. Layers in this pane correspond to the layers in the
Layers pane. This pane also provides access to tools and options
for working with the cells, frames, and images.

PhotoAnimator Tools

A PhotoAnimator Title Bar: Displays the
file name of the animation.

B Preview Pane: Displays a preview of
the animation which is always avail -
able and can be viewed from any dia-
log box as you work with animation
effects. This pane also provides
access to tools and options for work-
ing with the preview. See page 8 for
more information.

C Image Preview: Displays the anima-
tion and all visible layers.

D Layers Pane: Lists animation layers.
Functions like the Photoshop Layers
palette, allowing you to create, name,
hide, delete, and reposition layers.
See page 8 for more information.

E Grow Bar: Click and drag up or down
from the center to enlarge or reduce
the Filmstrip pane, allowing you to
show or hide layers.

F Filmstrip Pane: Displays the cells and
frames that make up the animation.
Layers in this pane correspond to the
layers in the Layers pane. This pane
also provides access to tools and
options for working with the cells,
frames, and images. See page 9 for
more information.

G Flicker Help Box: Displays a descrip-
tion of each tool or button function as
the mouse passes over it.

C

E

F

D

G

PhotoAnimator window

A

B

Tip

For a quick introduction to the
tools, windows, and basic opera -
tions in PhotoAnimator, we 
suggest you complete the first
tutorial “Getting Started—Basic
Animations” starting on page 22 of
this User Guide.

For an introduction to some of the
stunning special effects available
in PhotoAnimator, turn to Tu t o r i a l s
2 through 5 starting on page 32.  
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A Layer Name: Displays the layer by
name. Highlighted name indicates the
currently active layer in the Filmstrip
w i n d o w. Drag the name up or down
the list to reposition the layers.

B Show/Hide Layer: Determines whether
a layer is visible in the animation
image in the Preview pane. Eye icon
indicates showing, no Eye icon indi-
cates hidden. Only layers with an Eye
icon present will be included in the
animation when it is exported.

C New Layer: Click to create a new
(empty) layer.

D Delete Layer: Click to delete the
selected layer.

E Layer Options: Change layer name;
make visible or invisible.

B

PhotoAnimator window—Layers Pane

A

C D E

A Preview: Displays the full animation
sequence when the Player is on.
Displays the contents of the currently
selected frame when the Player is off.
Display is affected by the settings of
the layer Show/Hide buttons.

B Start/Stop: Press to start and stop the
animation. You can also press the
Spacebar to start and stop the
animation.

C Animation Player: Drag the slider to
interactively move through the full ani -
mation (affected by Layer settings).

D One-step buttons: Click back and
forth through the animation one frame
at a time.

E Loop: Places the Player in continu -
ous-play mode when depressed.

F Zoom: Click “+” to Zoom In (enlarge
the Preview), click “-” to Zoom Out
(reduce it). 

G Display Composite: Displays the com -
posite preview of all visible layers of
the current frame.

H Display Frame: Displays contents of
the currently selected frame only.

I Display Transition: Displays currently
selected frame transition.

G
H
I

PhotoAnimator window—Preview Pane

A

B C D E F
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A New Cell: Click to create a new
(empty) cell in the selected layer.

B Import Image: Click to create a new
cell in the selected layer and import
an image directly into it. Automatically
displays the appropriate Import
Options dialog.

C Clipboard Icon: Cut an animation cell
by dragging it to the clipboard icon.
Paste the cell by dragging the clip-
board icon to the desired location. To
copy the cell, Option+drag (Mac-
intosh) or Alt+drag (Windows).

You can also cut or copy to the clip-
board using the standard cut, copy,
and paste commands. Pasting the cell
places it at the end of any existing
cells in the layer.

D Open Effect Settings: Click to open
the Effect Settings dialog for the cur -
rently selected cell. You can also dou-
ble-click the cell to access the
Settings dialog once an effect has
been applied.

E Trash Icon: Delete (remove) the
selected cell.

F Frame: 300 maximum frames per
layer. Black border indicates currently
selected frame. 

G Animation Cell: Consists of one or
more frames. Filmstrip outer border
indicates currently selected layer.
Red inner border indicates currently
selected cell.

H Empty Cell: Shows a one-frame wide
empty cell.

I Cell End Marker: Drag to increase or
decrease number of frames in a cell.

J Frame place-holder: Empty position;
contains no frame or cell.

K Redraw progress bar: When com-
plete, indicate entire animation is
loaded into memory.

L Flicker Help Box: Displays a
description of each tool or function as
the mouse passes over it.

M Leave/Enter: Enter or exit the Nested
Sub-Animation work area.

N Animation Layers: These correspond
to the layers listed in the Layers Pane
(see page 8).

N

PhotoAnimator window—Filmstrip Pane

K L

G I JH

M

F
A

B

C

D

E



Frame: A single image; the smallest unit in PhotoAnimator.
Frames contain raw images. Maximum 300 frames per Layer.
Multiple frames make up a cell.

Cell: Consists of one or more frames. All the frames in a cell con-
tain the same image. Animation effects are applied to cells. The
effect may change the image gradually between the first frame of
the cell and the last frame of the cell, to create the piecs of the
total animation, such as transitions from visible to invisible, hori-
zontal or vertical movement over time, spins, etc.

Layer: Consists of one or more cells. Layers are combined to
create the full animation. A background layer, for example, might
consist of a single cell with multiple frames with no effects
applied to the image. A background layer would typically be the
bottom layer. An animation  layer, such as a filmstrip showing a
stunt plane in action, would typically be the top-most layer. The
animation layer might contain a number of different cells with a
different effect applied to each cell. When the cells are played in
succession they would simulate the movement of the plane: scal-
ing to show to perspective (movement far to near), rotation to
simulate spinning, etc. An example of this effect is shown in
Tutorial 1, which starts on page 22.

Effects: Effects allow you to create the illusion of movement.
Effects are applied to cells. Because they simulate movement,
effects are typically  applied to cells containing more than one
frame, and may affect the individual frames within the cell differ-
ently. Effects are accessed from the Effect menu in the menu bar.

Animation Player: The animation Player, located on the Preview
Pane, controls the image in the Preview window. The Player
allows you to play back the animation in a continuous loop or
frame by frame. Another Player, available from the dialog box of
each of the Effect Settings, allows you to step through the anima-
tion sequence of a single cell. By hiding and showing layers and
then stepping one by one through the frames of a single cell, you
can see how your Effect Settings on that cell will affect the over-
all animation. 

10

Tip

Once an effect has been applied
to a frame, simply double-click
the frame to open the appropriate
e ffect settings dialog box. Or
select any frame in a cell and
press C o m m a n d + T ( M a c i n t o s h )
or C o n t ro l + T ( Wi n d o w s ) .
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Animation Functions and Settings

Frames: Two Animation settings—Frame Size and Frame
Rate—allow you to specify how large the display window for
your animation will be, and to how quickly or slowly the frames
will play. The Frame Size dialog can also be opened by pressing
Command+F (Macintosh) or Control+F (Windows). Access the
Frame Rate dialog with Command+G (Macintosh) or
Control+G (Windows).

Layers: From the Animation menu you can create, delete, and
rename layers, and specify whether the selected layer is visible
or invisible. A filmstrip border indicates the currently selected
layer. Layer options can also be invoked using the buttons on the
left side of the Layers Pane (see page 8).

Cells: From the Animation menu you can create and delete cells,
and specify cell size. A red outline indicates the active cell. Cell
options can also be invoked using buttons and sliders on the
Filmstrip Pane (see page 9).

A Frame Size Settings

B Width and Height: Enter custom
frame size, in pixels.

C Common Sizes Buttons: Select from
eight commonly used sizes. Clicking a
size button enters the selected size
into the Width and Height fields.

D Cancel: Close the settings dialog
without making any changes.

E OK: Close the settings dialog and
apply the changes.

F Frame Rate Settings

G Total Frames: Displays the total num-
ber of frames in the animation. 

H Frame Rate (Frames/Second): Enter
the desired frequency in frames per
second.

I Duration (in Seconds): Displays the
duration of the animation based on
the number of frames and the speci-
fied Frame Rate.

C

G
H

I

B

Frame Size and Frame Rate Settings

A

F

D E

D E

Tip

To create a new Layer, press
C o m m a n d + L (Macintosh) or
C o n t ro l + L ( Wi n d o w s ) .

To create a new Cell, press
C o m m a n d + K (Macintosh) or
C o n t ro l + K ( Wi n d o w s ) .
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Effect Settings

PhotoAnimator provides five categories of effects (Basic, Image,
Mask, Transform, and Filter) that allow you to scale, rotate, spin,
apply gradient masks, invert, and more. By combining these
effects on different images over various size cells, the possibilities
for unique and eye-catching animations are unlimited.

All of the Effect Settings dialogs allow you to temporarily apply
the effect and preview the result on your animation without ever
leaving the settings dialog. This gives you tremendous freedom to
try out different effect settings and test your results without end-
lessly going back and forth between the settings dialog and the
Preview Pane.

To create an Effect:

1. Select a frame and open the effect you are interested in
by accessing it from the Effect menu. 

Effect options are described on pages 15 through 18.

2. When you have the effect you want, click “OK” to apply
the effect and close the dialog.

To Prev i ew the Effect without closing the Effect Settings dialog :

1. Move your windows around until you can see both the
Preview pane of the PhotoAnimator window and the
Settings dialog.

2. In the Settings dialog, click “Apply” to temporarily
apply the effect. 

3. M ove the slider on the player in the Settings dialog box
the see the effect on the selected cell in the Prev i ew Pa n e.

4. If you don’t like the effect, click “Revert,” or change the
settings, or click “Cancel” to close the dialog without
making any changes to the cell.

Repeat Last Settings
Once you have set an effect for a frame, that same effect can easi-
ly be applied to other frames. To repeat an effect, either drag the
cell border to the right, which instantly replicates the frame
(thereby replicating the effect), or select or create a new frame,
then select the first item on the Effect menu. The default setting
for newly created cells is “Image Repeat Settings.”

Tip

You can access the last-used
e ffect by pressing C o m m a n d + T
(Macintosh) or C o n t ro l + T
( Wi n d o w s ) .
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The ability to preview your cell effects
on the animation without closing the
dialog (controls G through K) is common
to all the Effects. Other controls shown
here may not be found in all Effect
dialogs.

A Import: Click to import an image into
the selected cell.

B Export: Click to export the selected
cell.

C Orientation Preview: Displays the
current orientation of cell contents.
Changes made to the Orientation
controls affect this Preview. Note:This
is not an animation preview window.

D Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

E Scale Settings: Specify Horizontal
and Vertical “From” size “To” size, as
a percentage of original size.

F Location: Displays a proxy of the loca-
tion (relative position) of the content in
the first frame of the cell. Drag the
proxy to specify a new starting loca-
tion, or enter coordinate values. See
page 14.

Move To Location: Click to allow frame
contents to be repositioned as the cell
progresses from first frame to last.
Drag to specify the frame ending
location, or enter coordinate values.
See page 14.

G Player: Move the slider to see the
current Effect Settings on the selected
cell. Click the right and left arrows to
move forward and backward through
the cell one frame at a time.

H Revert: Revert settings to the last-
saved state (undo Apply).

I Apply: Click to Apply the settings in
order to preview the effect. 

J Cancel: Click to close the dialog box
without making any changes to the
frame.

K OK: Click to Apply the effect and
close the dialog box.

L Animation Preview: This is the
Animation Preview pane of the
PhotoAnimator window. Look here to
view the animation as you operate the
Player in an Effect Settings dialog.

Common Effect Settings

G

F

E

H I J K

B C DA

L
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The Location Settings allow you to use a
proxy to indicate the relative position of
frame contents in the first frame of the
cell, and if “Move To” is enabled, the last
frame of the cell. PhotoAnimator automat-
ically adjusts frame content movement
between the other frames in the cell.

A Location Settings: Indicates frame
content starting and ending location in
the cell.

B Location: Displays a proxy of the rela-
tive position of frame contents in the
first frame of the cell. If no “Move To ”
location is specified, Location proxy
indicates position of frame content in
all frames of the cell. Drag proxy to
adjust frame content starting location. 

C “Move To” Enable: Click to access
Move To location controls.

D Move To: Displays a proxy of the rela -
tive position of the content in the last
frame of the cell. Drag proxy to indi-
cate frame content ending location .

E Frame Grid: Representation of frame
area as a square grid.

F Proxy: Red box sets the position point
of frame content relative to the frame.
White box represents actual frame
content location in (or even outside
of) the frame. (See K through O for
additional information.)

G X and Y Offsets: Indicates frame con-
tent offset from from proxy (red box),
in pixels. (See also O).

H Preview Controls: Allows you to pre-
view effects without leaving the dia -
log. (See page 8.)

I Cancel: Click to close the dialog box
without making changes.

J OK: Click to Apply the effect and
close the dialog box.

K Proxy: Indicates upper-left corner of
image is positioned in upper-left cor -
ner of frame.

L Proxy: Indicates lower-right corner of
image is positioned out of the frame
in the upper-left corner.

M Proxy: Indicates upper-left corner of
image is positioned in center of frame.

N Proxy: Indicates center of image is
centered in frame.

O Proxy Offset: Indicates center of
i m a g e is centered in frame, then off s e t
30 pixels right and 30 pixels down.

Location Settings and Frame Content Proxies

H

G

O

F

E

I J

A

B

K L M N

C D
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Basic Effects

Basic effect options include None (applies no effect), Solid Color,
Repeat Last, Repeat Next, and Nested Sub-animation.

Note: For examples of Effects, refer to Tutorials 1 through 5 start-
ing on page 22.

The Solid Color effect allows you to
color in your frames with a solid color.
When selected, the Solid Color effect
replaces any image already in the frame
with the selected color.

A Color Mode Pop-up: Select RGB,
CMY, HSV, Grayscale, or Web.

B Color Preview: Displays a preview of
the selected color.

C Picker: Access the system color picker.

D Preview Controls: Allows you to pre-
view effects without leaving the dia-
log. (See page 13.)

E Color Settings: Move the sliders until
the desired color appears in the Color
Preview, or enter values directly.

F Cancel: Click to close the dialog box
without making any changes to the
frame.

G OK:Click to Apply the effect and
close the dialog box.

Nested Sub-Animations

H Frame Action Pop-up: Select from
Left Align, Right Align, Center Align,
Left Repeat, Right Repeat, Center
Repeat, Scale, Loop Modulate.

I Frame Size: Opens the Frame Size
dialog (see page 11) to allow you to
select or set frame size.

J Location and Move To Location:
Allows you to specify starting and
ending locations. (See page 14.)

Basic Effects—Color and Nested Sub-Animation 

A
B

C

D
F

E

G

H

I

J

D
F

G
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Image Effects

Image Effects (Scale, Rotate, Spin) allow you to progressively
change the size and/or orientation of objects between the first and
last frame in the cell.

Note: For examples of Effects, refer to Tutorials 1 through 5 start-
ing on page 22.

Image Effects (Scale, Spin, Rotate)
allow you to change the size and orien-
tation of objects progressively between
the first and last frame in the cell.

A Import/Export: Allows you to import an
image into the selected cell or export
the selected cell.

B Orientation Preview: Displays the
current orientation of cell contents.
Changes to the Orientation controls
affect this Preview. Note:This is not
an animation preview window.

C Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

D Scale Settings: Specify Horizontal
and Vertical “From” size “To” size, as
a percentage of original size.

E Location and Move To Location:
Allows you to specify starting and
ending locations. (See page 14.)

F Preview Controls: Allows you to pre-
view effects without leaving the dia-
log. (See page 8.)

G Cancel: Click to close the dialog box
without making any changes to the
frame. 

H OK:Click to Apply the effect and
close the dialog box.

I Spin Settings: Specify how many rev -
olutions the image will spin by enter-
ing a value in “End.” Spin the image
horizontally, vertically, or both. Image
will appear to begin spinning in “mid-
stream” by entering a value in “Start.”

J Rotate Settings:Specify “From” Angle
and “To” Angle (in degrees), and indi-
cate Clockwise or Counter-clockwise
rotation. 

Image Effects—Scale, Rotate, and Spin 
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Spin
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Mask Effects

Mask Effects (Rotate and Scale) allow you to use the contents of
a frame as a mask, and change the size and orientation of the
mask gradually between the first and last frame in the cell.

Transition Effects

I m age Effects (Fa d e, Wi p e, B a rn Door, G radient Mask) allow
you to cre ate gradual transitions between the fi rst and last fra m e
in the cell.

Mask Effects (Rotate and Scale) allow
you to specify frame contents as a
mask, and to change the size and orien-
tation of the mask gradually between the
first and last frame in the cell.

A Import/Export: Allows you to import an
image into the selected cell or export
the selected cell.

B Orientation Preview: Displays the
current orientation of cell contents.
Changes to the Orientation controls
affect this Preview. Note:This is not
an animation preview window.

C Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

D Default Fill Pop-up: Select Black or
White as the Mask fill color.

E Accumulation Pop-up: Select
Intersection or Union.

F Rotate: Specify “From” Angle and
“To” Angle (in degrees), and indicate
Clockwise or Counter-clockwise
rotation. 

G Location and Move To Location:
Allows you to specify starting and
ending locations. (See page 14.)

H Preview Controls: Allows you to pre-
view effects without leaving the dia -
log. (See page 8.)

I Cancel: Click to close the dialog box
without making any changes to the
frame. 

J OK:Click to Apply the effect and
close the dialog box.

K Scale Settings:Specify Horizontal
and Vertical “From” size “To” size, as
a percentage of original size. 

Mask Effects—Rotate and Scale
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Transition Effects (Fade, Wipe, Barn D o o r,
Gradient Mask) allow you to create tran-
sitions between the first and last frame
in the cell.

Fade, Barn Door, Wipe

A Accumulation Pop-up: Select
Intersection or Union.

B Transition From and To: Specify
transition as a percentage of original
(0 to 100%).

C Transition Settings: Specify orientation,
direction, and start-to-end preferences.

Gradient Mask

D Import/Export: Allows you to import an
image into the selected cell or export
the selected cell.

E Orientation Preview: Displays the
current orientation of cell contents.
Changes to the Orientation controls
affect this Preview. Note:This is not
an animation preview window.

F Orientation Controls: Click the appro-
priate arrow to change the orientation
of cell contents.

G Direction Pop-up: Select Black to
White or White to Black transition.

Mode Pop-up: Select None to All or A l l
to None.

Edge: Changes intensity of mask.

H Preview Controls: Allows you to pre-
view effects without leaving the dia-
log. (See page 8.)

I Cancel: Click to close the dialog box
without making any changes to the
frame. 

J OK: Click to Apply the effect and
close the dialog box.

Transition Effects—Fade, Wipe, Barn Door, Gradient Mask
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Importing and Import Options

Within PhotoAnimator you can apply limitless special effects to
images, but first you must bring those images into the Photo-
Animator program. You do this using the Import command.

You can import any graphic file saved in either Photoshop native
format (.psd) or in GIF format (.gif). Imported files can be multi-
frame or multi-layer files as well as single frame or single image
files. 

Photoshop File Format (.psd)

A Layer Mapping Options: Select from
Horizontal Inline (Frames), Horizontal
Grouped (Frames), Vertical Grouped
(Layers).

B Layer Import Direction: Select from
Top to Bottom or Bottom to To p .

C Import Items: Options are Layer
Images, Layer Masks, Composite
Image, and Alpha Channels.

D Cancel: Cancel the Import operation .

E Import: Import the image file using
the current selections.

GIF File Format (.gif)

F Frame Import Method: Select
Composite Inline (single layer),
Composite Grouped (single layer),
or Disassembled (multi-layer)

G Include Background Color Layer 

H Adjust for Frame Delays: Imports
additional frames to account for frame
delay of imported GIF. For example, if
you import a GIF that happens to
have a frame rate of 6 Frames per
Second, and a particular frame of the
G I F was set to delay for 1 second,
PhotoAni-mator will generate 6 cells
to adjust for this delay.

A

B
F

G
H

C

Import Options dialog

D E

Photoshop

GIF

Tip

You can also Import images by
pressing C o m m a n d + I ( M a c -
intosh) or C o n t ro l + I ( Wi n d o w s ) .
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Exporting and Export Options

P h o t o A n i m ator animations can be ex p o rted as GIF A n i m at i o n s
( . gi f ) , as Photoshop laye rs (.psd), or as PhotoAnimat o r
t e m p l ates. ( For more info rm ation on Export i n g, see Tu t o rial 5
s t a rting on page 59.)

Note: Animations can also be saved in the normal way (using the
Save and Save As. . . commands) as PhotoAnimator files (.paf).

Export Options allow you to save anima-
tions in one of three ways: Animated
GIF, Photoshop native format, and
PhotoAnimator format.

A Format: Export options dialog for the
Animated GIF format.

B Animation Preview: Allows you to
preview how the animation will look in
with the specified export options
applied.

C Web Options: Dithering, Color Set,
Maximum Colors, Interframe
Transparency Option.

D Loop Options: Loop Forever, Play
(specify number of times).

E File Statistics: File Size and
Download Time are calculated based
on the option settings when
Calculate/Preview is initiated.

F Calculate/Preview: Click here to apply
the indicated settings to the Preview.

G Cancel: Close the dialog without
applying changes.

H Export: Exports the animation in the
format indicated at the top of the dia-
log box, according to the indicated
settings.

I Player: Allows you to preview the ani -
mation as it will appear when export-
ed with the indicated settings.

J Preview Zoom: Click “+” to zoom in,
click “-” to zoom out.

K Photoshop Format: Exports the
animation in native Photoshop format.

L PhotoAnimator Format: Exports the
animation in native PhotoAnimator
format. Allows you to create an
animation template.

Export Options dialogs

C

D

E

F

G H I J

BA

K L

Tip

You can Export your animations
by pressing C o m m a n d + E ( M a c -
intosh) or C o n t ro l + E ( Wi n d o w s ) .

Photoshop PhotoAnimator

Animated GIF
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Preferences

Preferences affect some operations of the PhotoAnimator
program. 

Application Start-Up: Use this preference to specify whether,
when launched, PhotoAnimator queries you for a frame size to
begin a new animation; presents the system’s “Open File” dialog
so you can open an existing animation; or simply opens without a
document.

Undo/Redo: Undo operations require additional memory, so you
would want to keep this number low if you have limited system
memory. (Maximum 100 levels of Undo.)

Transparency Background: Select this option to change the
color, brightness, and checker-pattern size of the transparency
background in the animation Preview window.

A Application Startup: Controls the
PhotoAnimator startup process. 

Do Nothing: Open PhotoAnimator
without a document.

New Document Dialog: When starting
PhotoAnimator, present the
PhotoAnimator “Frame Size” dialog.
(This is the default.)

Open Document Dialog: When start -
ing PhotoAnimator, present the File
System “Open” Dialog.

B Undo/Redo: Specify maximum levels
of Undo/Redo. The larger the number,
the more system memory is required.

C Transparency Checkerboard: Allows
you to specify the size and color of
the Preview window background
checkerboard.

D Cancel: Close the Preferences dialog
without making any changes.

E OK:Close the Preferences dialog and
apply the changes.

Preferences dialog

A

B

C

D E



In this tutorial you will learn how to create a simple animation,
while being introduced to the tools and operations available in
PhotoAnimator. Once you’re familiar with the program, we
suggest you check out the rest of the tutorials starting on page 32.
These tutorials will introduce you to some of the special effects
possible with PhotoAnimator, and hopefully get you started
immediately creating fun and eye-catching animations.

Airplane Animation

We’re going to be creating an animation of an airplane flying over
a cloudy sky. There are three components to this animation: an
airplane, the airplane’s shadow, and a cloudy sky.

First we’ll make the cloudy background texture scroll seamlessly,
then to complete our animation we’ll make the airplane and its
shadow bounce slightly up and down in relation to one another as
if the airplane were encountering some turbulence.

1. Open the file “airplane_start.paf” located in the Tutorial 1
folder by double-clicking its icon.  (See page 4 for Mac-
intosh and page 5 for Windows Tutorial folder locations.)

— or —

Open the PhotoAnimator application, then click “Cancel”
to close the New Animation dialog. Select “Open” from the
File menu, and locate the “airplane_start.paf” file.

At start u p , P h o t o A n i m ator (by default) assumes that you wa n t
to cre ate a new document and displays the New A n i m ation dia-
l og box. This time we want to open an existing fi l e, so cl i ck the
Cancel button and open the file from the menu instead.

2. Familiarize yourself with the PhotoAnimator window.

The PhotoAnimator window is divided into three panes. The
top left pane is the called the Layers Pane and functions very
similar to the Layers palette found in Adobe Photoshop. This
is where you can create, name, hide, delete and reposition
layers. The Layers Pane is described in detail on page 8.

The top right pane is called the Preview Pane. From this pane
you have access to what the animation looks like. The Preview
is available at all times in PhotoAnimator, even from the dia-
log boxes where you apply animation effects. 
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Tip

There are five tutorials included in
this PhotoAnimator User Guide. To
get the most value from the tutori-
als, we suggest you do them in the
order presented. However, it isn’t
necessary—please use them in
whatever way helps you the most.

Having said that, we do encourage
you to complete the Airplane
Animation (Tutorial 1) first, as it
provides an introduction to the
basic tools and functions in the
application. Tutorials 2 through 5
assume that you have this basic
knowledge.

The tutorial sample files referenced
in the tutorials can be found in the
“Tutorials” folder inside the Photo-
Animator™ 1.0 folder on your hard
drive. (For exact file locations, see
“Installation,” pages 4 and 5.)

Tip

You can specify what action Photo-
Animator will take at startup from
the Edit > Preferences dialog.
Options are: Do Nothing; display
New Document dialog; display
Open Document dialog.

Tutorial 1: Getting Started—Basic Animations



From the Preview Pane you can play and stop the animation
using the animation Player. Press the green arrow to start the
animation. When the animation starts the arrow will turn red;
press the red arrow to stop the animation. The Preview Pane is
described in detail on page 8.

The bottom pane of the PhotoAnimator window is the
Filmstrip Pane. This is where you will see your animation
cells and frames. Each row in the Filmstrip Pane is called a
Layer, and the Layers here correspond to the Layers in the
Layers Pane above. The Filmstrip Pane is described in detail
on page 9.

The horizontal divider between the top two panes (Layers and
Preview) and the bottom pane (Filmstrip) allows you to adjust
the size of the Filmstrip Pane so that you can see more film-
strip rows (layers) at a time. Simply drag the divider up or
down. You can also adjust the size of most PhotoAnimator
windows and dialog boxes using the grow button on the bot-
tom-right corner of the window.

A Flicker Help Box at the bottom of the PhotoAnimator
window displays a brief description of the buttons and
functions in the window as you pass the mouse over them.
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Tip

To quickly start or stop the anima-
tion, press the Spacebar.

Use the Right and Left Arrow
keys to move forward and back-
ward one frame at a time. 

Use the Up and Down Arrow keys
to move up and down one layer at
a time.

Tip

PhotoAnimator gives you multiple
levels of Undo, so don’t be afraid
to experiment—you can undo as
many times as necessary to get
back to a known condition.

Preview Pane

Layers Pane

Filmstrip Pane



3. Add an image to the animation by Importing it.

Since there will be three elements in the animation, we creat-
ed three layers—one layer to contain the animation effects for
each of the three images. We already imported images into the
“Airplane” and “Shadow” layers; now you will bring in the
image of the clouds and place it into the “ C l o u d s ” l aye r.

• Click the “Clouds” layer in the Layers Pane to select it,
then select “Import” from the File menu. 

• Locate the “clouds.psd” file in the “Tutorial 1” folder.

Note: PhotoAnimator works with only Photoshop native
files and GIF images. You can use Photoshop, CorelDraw,
or any number of image manipulation programs that can
save images in either native Photoshop (.psd) or GIF (.gif)
format.  

• On the Import Options dialog, leave the settings as they
are (an image of this dialog is shown in the sidebar) and
click “Import.”

A clouds texture will be placed in the “Clouds” Layer, and
will be displayed in the first frame of the first cell of the last
layer (bottom row) in the Filmstrip Pane.

Examine the Filmstrip and Layers Pane. Notice that when
you select a layer in the Layers Pane, the corresponding
layer in the Filmstrip Pane shows a cell highlighted by a
filmstrip icon and a red rectangle. The filmstrip image
shows you the selected layer; the red rectangle outlines the
currently selected cell; and a black outline around the frame
indicates the selected frame.
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Tip

You can also import an image into
an existing layer using the
Import button on the
Filmstrip Pane Toolbar.
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Also notice (in the Filmstrip Pane) that each of our three
layers now has one cell, and each cell has one frame in it.
Each frame contains one of the imported images. 

If you examine the layers in the Filmstrip Pane you’ll notice
that they are in the same order as the layer names in the
Layers Pane. By moving the layer names up and down the
layers list you can reorder the layers and dramatically alter
our effects.

D o n ’t be too concerned if all this doesn’t make a lot of sense
right now—the connection between laye rs , c e l l s , and fra m e s
will become more clear as you work on the animation.

4. Now let’s extend the clouds texture to make a longer
sequence for our animation. 

• On the Clouds layer in the Filmstrip Pane, position your
mouse on the right edge of the cell border. When the
cursor changes to a double arrow, drag this border out
just past the position numbered “10.”

When you  release the mouse you will see that PhotoAnima-
tor has expanded the clouds texture over ten frames auto-
matically.

Notice that now the red highlight rectangle includes all ten
frames of the clouds texture. PhotoAnimator treats this
group of 10 “frames” as one “cell.” You can change the
number of frames in a cell at any time by dragging its bor-
der to a new position.

Note: You can increase or decrease the number of frames in
a cell at any time by dragging the cell’s right-hand border.
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Any Effect Settings applied to the cell will include the newly
created frames.

Click on a few of the frames one at a time and observe what
happens in the Preview Pane. If you click on any frame
other than the first frame, the airplane and the shadow will
disappear. Clicking on frames  2 through 10 in any layer
results in the same texture appearing in the Preview Pane.

5. Make the clouds appear to move across the sky.

The most important part of creating an animation is applying
the special effects that make single-cell graphics look, well...
animated! In PhotoAnimator there are a number of different
types of effects you can apply to your images, and we’ll touch
on most of them over the course of these tutorials. 

In our first effect, we’ll show you how to simulate movement
by having the clouds appear to move across the sky.

• Isolate the cloud layer in the Preview so it will be easier
to see the new effect on it: In the Layers Pane, click the
eye icon for both the Airplane and Shadow layers so that

the eye disappears. 

This hides the Airplane and Shadow layers, effectively iso-
lating the Clouds layer.

• Open the Effect Settings for the clouds texture image: In
the Clouds layer of the Filmstrip pane, double-click on
any frame in the clouds texture cell. 

This opens the “Image Repeat Settings” dialog box. All
Image Settings are Effects (the other Effect categories are:
Basic, Mask, Transition, and Filter). 

By default, PhotoAnimator applies the Image Repeat Setting
to all newly created cells. Image Repeat tells PhotoAnimator
to do just that—repeat, or reproduce, the currently selected
image in each frame of the cell.

Tip

To examine or modify the Effect
Settings currently applied to a cell,
double-click any frame in the cell.
Or press Command+T (Macintosh)
or Control+T (Windows).

To change the type of effect
applied to the cell, select the new
effect from the Effect menu in the
menubar.
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Look carefully at the preview window in the Image Repeat
Settings dialog box. Notice that the clouds texture is wider
than the texture shown in the Preview on the PhotoAnimator
window.

In fact, it is twice as wide. The frame size of this animation
is 100 by 100 pixels, but the clouds texture we imported
from the clouds.psd file is 100 by 200 pixels. We created the
clouds.psd file as a “seamless” texture so that after we ani-
mate the texture, it will appear as if the airplane is flying
over an endless stretch of clouds.

• Set the start position for the clouds texture: Click on the
small white proxy in the upper left corner of the
“Location” field and drag it around the grid (both the
white and red boxes will move). Position these little
boxes over the left center grid point, so that the tiny red
box is centered inside the white box. 

The red box sets the proxy, or position point of the image.
The white box represents the location of the image. See
page 14 for a more complete description of this feature.
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• Enable the “Move To” option by clicking its box (verify
that there is now a checkmark in the box). 

The proxies under Move To should now be available.

• Drag the Move To proxies over the right center grid
point, keeping the red box centered inside the white box.

• Move the Image Repeat Settings dialog box so that you
can see both the Preview Pane on the PhotoAnimator
window and the open Image Repeat Settings dialog.

• In the Image Repeat Settings dialog, click the “Apply”
button to temporarily apply the effect to the cell. 

• Now drag the slider on the Player in the Image Repeat
Settings dialog (its above the Revert and Apply buttons)
to the left and right. Watch the Preview.

The cloud texture in the Preview will move back and forth.
The movement hasn’t yet been permanently applied to the
cloudy texture cell: Clicking the Apply button lets you
Preview the effect on the overall animation without actually
leaving the dialog box. At this point, if you were unhappy
with the results of your effect, you could click the “Revert”
button to undo the effect and start over. For now, just leave
the effect the way it was.

• When you’ve finished playing with your new effect, veri-
fy that the starting and ending locations for the cell
frames are as shown above, then click “OK.”

This closes the dialog Effect Settings dialog box and applies
the effect to the cell.

Click the “Loop Playback” button in the Preview Pane.

This puts the Player into continuous play mode.
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Click the Play button (the little green arrow) or tap the
Spacebar to play the animation. 

If you watch carefully, you will see that the cloudy texture
loops seamlessly when the animation plays from the last
frame to the first. 

Click the Stop button (the red square ) or tap the space-
bar again to stop the animation.

6. Now include the airplane and its shadow in the animation.

Unhide the Airplane layer and the Shadow layer by
cl i cking the Show/Hide box so that the eye icon is visibl e.

• Select the Airplane layer by clicking on it either in the
Layers Pane or the Filmstrip Pane.

• In the Filmstrip Pane, extend the airplane cell to 10
frames. Repeat this process for shadow cell, expanding it
to ten frames as well. 

Preview the animation by pressing the Play button on
the Animation Player. The airplane now appears to be
flying over our cloudy sky.

Not bad so far, but with PhotoAnimator we can easily make
our animation more interesting. What you are going to do
next is make the airplane appear to bounce up and down as
it flies through the air. You will do this by adjusting the
scale of the airplane and its shadow over time. When you
are done, the airplane will appear to rise and fall. The
airplane’s shadow will appear to shrink as the airplane rises,
and appear to grow as the airplane falls, mimicking how
shadows act in the real world.

7. Add some additional effects to the airplane, making it
appear to encounter turbulence.

You’ll need to create another cell of airplane frames for the
next effect, and you’ll do that by copying and pasting the first
cell in the same layer as the original. 

• Copy the five-frame airplane cell: Click in any frame of
the cell to select it, then select Edit > Copy. Or use the
standard keyboard shortcut [Command+C (Macintosh)
or Control+C (Windows)].

• Without doing anything else, Paste the cell: Select Edit >
Paste, or use the standard keyboard shortcut
[Command+V (Macintosh) or Control+V (Windows)].

Tip

You can toggle the animation
Player on and off by pressing the
Spacebar.

Tip

You can drag-copy a cell to a new
location by holding down the
Option (Macintosh) or ALT
(Windows) key while dragging. 
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Notice that the new cell was pasted to the right of the cell
that was copied. PhotoAnimator assumes when you copy a
cell that you wish to expand the animation of the copied
image, and automatically places it in the proper sequence.

• Repeat this process to create a second cell of the airplane
Shadow image on the Shadow layer.

When you are finished, the Airplane and the Shadow layers
should each contain two five-frame cells.

• Select the first cell on the Airplane filmstrip layer, then
select Image > Scale. . . from the Effects menu. 

This will open the Image Scale Settings dialog box. 

Notice that we didn’t instruct you to double-click the cell to
open the Effect Settings dialog; that’s because (as you may
recall) the current settings for the cell are “Image Repeat
Settings,” and you want to apply a different effect to the
cell.

• In the Image Scale Settings dialog for the fi rst cell, set the
H o ri zontal and Ve rtical values for the “ Fro m ( % ) ” to  90.

• Click “OK” to apply the settings and close the dialog.

• Now select the second cell on the Airplane filmstrip layer,
and again select Image > Scale. . . from the Effects menu. 

This opens the Image Scale Settings dialog for the second
airplane cell.

• Set the Horizontal and Vertical values for the “To(%)”
to 90, then click “OK.”
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Now play the animation. 

The airplane should appear to bob up and down, while the
shadow remains constant.

8. The next, and final thing you need to do is animate the air-
plane’s shadow.

• Select the first cell on the Shadow filmstrip layer, then
select Image > Scale. . . from the Effects menu. 

This will open the Image Scale Settings dialog for the
shadow.

• In the Image Scale Settings dialog, drag the proxy to the
center of the centerpoint of the Location grid, being sure
to center the red box inside the white box.

• Also set the Horizontal and Vertical values for the
“To(%)” to  80.

• Click “OK” to apply the settings and close the dialog.

• Select the second cell on the Shadow filmstrip layer, then
select Image > Scale. . . from the Effects menu. 

• In the Image Scale Settings dialog, again drag the proxy
to the center of the centerpoint of the grid, being sure to
center the red box inside the white box.

• This time, set the Horizontal and Vertical values for the
“From(%)” to  80. 

Play the animation. 

Now the shadow appears to shrink away from the airplane
as the airplane rises, and expands towards the airplane when
the airplane falls. 

That completes your first animation in PhotoAnimator.
Congratulations—and happy animating!
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In this exercise, you will learn about one of PhotoAnimator’s
distinctive features—its ability to animate masks in addition to
images. This tutorial will focus on the Mask options of
PhotoAnimator Effects. 

Mask Effects—The “Click Here Button”Animation

In this tutorial you will create a half-size banner ad. The banner
will display the text “What are you waiting for?” for a several
seconds. The text will be set on a yellow shape. You will then
make the text disappear and use a mask to cut away at the yellow
shape, revealing an orange button below the shape that has the
words “Click Here” on it. Finally you will make a blue-striped
radial graphic rotate around a few times to help accentuate the
“Click Here” button.

1. Open the PhotoAnimator application. When the “New
Animation” dialog appears, click Half Banner (234 x 60).

The factory default setting is to have the New Animation dia-
log box appear automatically when PhotoAnimator is
launched. If this dialog didn’t appear, select File > New. This
will give you access to the dialog.

Note: If the New Animation dialog appears and you wish it
didn’t, you can change this preference in Edit > Preferences.

PhotoAnimator provides a range of common animation sizes
for you to choose from. If a size you need is not listed, you
create a custom size simply by entering the dimensions in the
Height and Width fields.

Tip

There are five tutorials included in
this PhotoAnimator User Guide. To
get the most value from the tutori-
als, we suggest you do them in the
order presented. However, it isn’t
necessary—please use them in
whatever way helps you the most.

Having said that, we do encourage
you to complete the Airplane
Animation (Tutorial 1) first, as it
provides an introduction to the
basic tools and functions in the
application. Tutorials 2 through 5
assume that you have this basic
knowledge.

The tutorial sample files referenced
in the tutorials can be found in the
“Tutorials” folder inside the Photo-
Animator™ 1.0 folder on your hard
drive. (For exact file locations, see
“Installation,” pages 4 and 5.)

Tutorial 2: Working with Masks
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2. Create two new layers.

Create a new layer by clicking on the New
button in the Layers pane. Name the layer

“Spin Mask”. 

Create another layer and name it “Light
Blue”.

3. Expand all three layers out to 30 frames.

• Select the “Background” layer in the Layers Pane. In the
Filmstrip pane, click the New Cell button. This
will create a new cell in the Background layer.

Drag the cell’s right edge to the right so that the cell con-
tains thirty (30) frames.

You can repeat what you just did to create a thirty frame cell
in each of the other two layers, but you’re learning, so let’s
do it a different way this time.

• Copy the cell by pressing and holding the Option
(Macintosh) or ALT (Windows) key, then drag and drop
the cell from the Background layer (in the Filmstrip
Pane) into the “Spin Mask” layer.

This places an empty cell 30 frames wide in the Spin Mask
layer.

• Repeat for the “Light Blue” layer.

At this point you should have three layers each containing a
thirty-frame cell. 

Tip

You can also create a new Layer
by pressing Command+L (Mac-
intosh) or Control+L (Windows).

Tip

You can also create a New Cell by
pressing Command+K (Macintosh)
or Control+K (Windows).
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4. Now you’ll add some color and import a mask to create a
nice rotating animation effect.

• Click on the Background layer to select it , then select
Effect > Basic > Solid Color. . . from the menubar. Change
the RGB values to Red: 0, Green: 0, and Blue: 153, then
click OK. 

• Repeat this process on the Light Blue layer using RGB
values of Red: 0, Green: 153, and Blue: 204.

This creates two layers filled with different shades of blue.

5. Now you’ll will mix the two blue layers together and use a
Mask to create a radial design between the colors.

• Click on any frame in the Spin Mask layer to select the
cell.

• Choose Effect > Mask > Repeat. . . from the menubar.

In the Mask Repeat Settings dialog, click the Open
File button and select the “Spinmask.psd” file

from the Tutorial 2 folder.

Tip

Don’t forget that PhotoAnimator
provides mutiple levels of
Undo.Simply press Command+Z
(Macintosh) or Control+Z
(Windows) as many times as nec-
essary to “wind back” your actions.  

You can Redo an Undo operation
with Command+Y (Macintosh) or
Control+Y (Windows).
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Note: You may have noticed that the “Spinmask.psd” file is
actually much larger than the 234 x 60 size of the
animation. This is so that the edge of the mask is never seen
in the frame boundaries as it rotates. PhotoAnimator allows
you to use masks that are smaller or larger than the
animation frame size.

• Click “OK” to save the mask into the cell and close the
dialog box.

The two colors should now appear to form a radial design.
However, if you press the Play button, nothing appears to
happen. It’s time to generate some motion!

6. Adjust Cell size to prepare for the mask animation.

• Reduce the Spin Mask layer cell size to 24 frames (re c a l l
t h at it is curre n t ly 30 frames) by dragging the ri g h t
b o rder of the cell just past the number 24.

This next step you could do by dragging as you did earl i e r,
but let’s try something new.

• D u p l i c ate the Spin Mask cell, then reduce the new cell
to 6 fra m e s : C l i ck in any frame of the Spin Mask cell,
then Cut and immediat e ly Pa s t e. Select A n i m ation >
R e s i ze Cell from the menu b a r. Enter “ 6 ” in the Number
of Frames box .

This duplicates the Spin Mask cell and places the new cell
to the right of the copied cell, and reduces the size of the
new cell from 24 to 6 frames.
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The Spin Mask layer should contain two cells. The first cell
should be 24 frames long, and the second 6 frames long.
Each cell should contain the same mask that we imported in
step 5.  

7. Create a short spinning effect for the Mask.

• In the Fi l m s t rip Pa n e, cl i ck any frame in the second cell
of the Spin Mask layer (the cell with 6 frames) to select it.

• Select Effects > Mask > Rotate. . . from the menubar.
Enter the following values:

From: 0°    To: 50°    Clockwise (CW)

• When you have finished entering the Mask Rotate effect
settings, click “OK” to apply the settings and close the
dialog.

Preview the animation by pressing the Play button in the
Preview Pane. Now the blue-striped radial design should
stay static for a few seconds and then rotate a few times.
It you turn on the Loop button in the Preview Pane you
will notice that the rotation loops seamlessly.

Up to this point you have been working on the background
for the animation. Now you are going to add in all of the
other elements.

Tip

When you copy and paste a cell in
PhotoAnimator, the pasted con-
tents are added to the right of the
currently selected cell. 
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8. Create five new layers to hold the rest of the animation ele-
ments.

• Select the Light Blue layer in the Layers Pane.

You select this layer because you want your new layers to
be positioned above this one, and PhotoAnimator inserts
new layers above the selected layer.

• Create five new layers and name them in exactly this
order: “Border,” “Click Here,” “Diamond Mask,”
“Shield,” and “What Are You Waiting For.” (“What Are
You Waiting For” should be the last and top layer.)

When you are finished you should have eight layers listed in
the Layers Pane, and each layer should have a unique name.

9. Import and examine a multi-layer file (“why_wait.psd”).

• Click on the Border layer in the Layers Pane and choose
Import from the File menu, or press Command+I
(Macintosh) or Control+I (Windows) . 

• In the Open dialog box, select the “why_wait.psd” file
from the Tutorial 2 folder.

• When you’ve located the “why_wait.psd” image, click
“OK.”

The Import Options dialog will be displayed.

• Verify that the options in the Photoshop Import Options
dialog are at their default settings: Horizontal Inline
(frames);  Top to Bottom; and all the Import Items boxes
unchecked.

• Click “Import.”
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There are four images in the “why_wait.psd” file. Notice
that after you imported the file, four cells were added to the
Border layer. Each cell corresponds to a separate layer in the
file you just imported.

You must now move each of these images onto their own
layer.

10. Move each of the imported images from the Border layer
to the appropriate layer.

Since the new images in the cells are very small, click the
Checkerboard icon in the Preview Pane. This will isolate
the Preview to just the contents of the selected frame,
which will allow you to easily identify each element.

• To help you see the target Filmstrip layers where you’ll
be dragging the new cells, enlarge the window as much
as you can.
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• Click and drag the first cell (it should be the “What Are
You Waiting For?” image) into the “What Are You
Waiting For layer.” This will be the top layer in the
Filmstrip Pane.

• The next image should be the yellow shield. Click and
drag this image to the “Shield” layer. The Shield layer is
second from the top.

• Locate the “Click Here” button and drag it to the “Click
Here” layer.

• The remaining cell in the Border layer should display a
green border image. Leave this cell where it is.

Note that you still have one empty layer, the layer named
“Diamond Mask.” We will be tending to this omission short ly.

Since you have finished moving the cells around, you can
restore the composite (multi-layer) Preview in the
PhotoAnimator window by clicking the Show Composite
button at the top of the Preview Pane.

11. Resize the Border, Shield, and Click Here layers to be 30
frames wide.

• Click any frame in the Border layer cell, then select
Animation > Resize Cell . .. . When the dialog box opens,
enter 30 in the Number of Frames box.

• Repeat this step for the Click Here and Shield layers.

12. Resize the Diamond Mask and What Are You Waiting For
layers to be 15 frames wide.

• Select the Diamond Mask layer, then create a new cell in
it by clicking on the New Cell icon in the Filmstrip Pane.
Resize this cell so it has 15 frames in it.

• Resize the cell in the What are You Waiting For layer to
15 frames as well.

Click the Play button in the Preview Pane. The message
“What are you waiting for?” should display for 15
frames and then disappear.

Tip

You can automatically create a
new cell in an empty layer and size
the cell at the same time. Simply
drag the empty cell border to the
right until you’ve created as many
frames as you need. New frames
will be created as you go along.

Tip

You can toggle the animation
Player on and off by pressing the
Spacebar.

Tip

To quickly determine which layer
an image has been placed in, click
the image. This selects the layer,
causing the layer name in the
Layer Pane list to be highlighted.
Scroll the list, if necessary, to bring
the selected layer name into view.
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Now you will use a Mask to make a diamond-shaped hole
appear on the yellow shield, which will reveal the “Click
Here” button for several frames.

13. Import the last image and apply its special effect.

• Select the cell in the “Diamond Mask” layer.

• C o py and Paste the cell to cre ate a duplicate cell to the
right of it. Resize this duplicated cell from 15 frames to 9
f rames (the second cell will end at the Frame 24 marke r ) .

• Verify that this second cell (Frames 16 through 24) is
selected (red border around it), then select Effect >
Mask > Scale. . . from the menubar.

Click the Open File button in the Mask Scale Settings
dialog box and select “Diamondmask.psd” from the
Tutorial 2 folder, then click Import. 

You may want to scroll the Settings preview in order to see
the diamond mask. It isn’t necessary to see it, however—if
you imported it, it’s there! 

• Enter the following effect settings:

Default Fill: White
Accumulation: Intersection
Horizontal and Vertical “From(%)”: 0 (zero)
Horizontal and Vertical “To(%)”: 100 

• Click “OK” to Apply the effect and close the dialog.

Preview the animation. 

A diamond-shaped hole should appear in the yellow shield
between Frames 16 and 24. However, after Frame 24, the
shield goes back to fully covering the “Click Here” button.
Let’s change that.
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14.  Add another cell to fine-tune the animation.

• Copy and Paste the second cell on the Diamond Mask
layer.

This creates a third cell on the Diamond Mask layer.

• Resize the newly pasted cell so that it contains 6 frames
(this third cell will end at the Frame Number 30
marker). 

• Double-click anywhere in this cell to open the Mask
Scale Settings dialog box. 

• Change the Horizontal and Vertical “From(%)” values
to 100, then click “OK.”

Verify that the “Loop” button is pressed so the anima-
tion will play continuously.

Play the animation.

The final animation should display the text “What are you
waiting for?” for a few seconds. Then the text should disap-
pear and a diamond-shaped hole should get larger and larger
until the “Click Here” Button is fully visible. The “Click
Here” button should remain visible for six frames. Finally,
the radial blue strips should rotate a few times, then the ani-
mation should start over.

That completes the “Click Here Button” animation, but before
you wrap up your work with Masks, let’s look at some layered
masking effects.
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Layered Masks—The “Radiation” Animation

This example demonstrates that you can combine masks on differ-
ent layers to create interesting animation effects. In the next tutor-
ial (Tutorial 3) you will learn how to make and use Gradient
Masks—a unique and powerful PhotoAnimator effect tool that
gives you more creative capability than any animation program of
its type.

1. Open the “Radiation” animation.

• Select File > Open. . . from the menubar.

• Locate the  “Radiate.paf ” file located in the Tutorial 2
folder on the Extensis CD.

• Click “OK” to open the animation file.

Notice that you can store PhotoAnimator files in
PhotoAnimator’s own proprietary format (.paf). This allows
you to save animations without exporting them. You can
also import “.paf” files into PhotoAnimator—we’ll talk
about import and export options in our final tutorial
“Exporting Animated GIFs” starting on page xx.

2. Play the animation and observe the animation effect. 

The holes that form a classic radiation symbol gradually open
up to reveal an orange-colored backdrop. Then a wild transi-
tion occurs between orange and yellow (this effect was
achieved with a Gradient Mask transition which will be cov-
ered in the next tutorial). Finally, the radiation holes close
back up again.
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We created the opening and closing of the radiation holes by
layering two masks. The first mask, on the “Static Mask”
layer, is stationary. The second mask, on the “Rotating Mask”
layer, employs the same mask that was used on the Static
Mask layer. However, the mask on the Rotating Mask layer
rotates. When the second mask layer rotates relative to the
first, the holes of the radiation appear to open and close.

In the next tutorial (Tutorial 3), you will learn about
Transitions and see how to use a Gradient Mask—a unique
and powerful animation tool unique to PhotoAnimator.
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In this exercise, you will learn about another one of
PhotoAnimator’s distinctive features—its ability to produce sim-
ple to complex transition effects. This tutorial will focus on the
Transition options of PhotoAnimator Effects. 

Barn Door and Dissolve—The “Web Button”Animation

PhotoAnimator makes it easy to apply transition effects to cells.
Basic transitions such as wipes, fades, and “barn door” transitions
are directly supported using the dedicated Effects commands. 

PhotoAnimator compliments these “bread and butter” transition
effects with a feature called “Gradient Mask.” The Gradient Mask
feature uses a mask saved as a Photoshop (.psd) or GIF (.gif) file
to create any number of unique transition effects. 

There are three exercises in this tutorial:

• In the first exercise, you will learn how to create basic transi-
tion effects such as a Barn Door transition. 

• In the second exercise, you will learn how to create a Gradient
Mask transition. 

• In the third exercise, you will look at a ready-made example file
to see just how dynamic and complex Gradient Mask transitions
can be.

Barn Door and Dissolve Transitions

In this tutorial you will add animation to a simple Web button.
The button will grow into view using the Barn Door transition. A
glow that temporarily highlights the button will fade in and out of
view. And finally, when the button is fully visible, the word
“Extensis” will dissolve into view over the button. You will
accomplish all of this with transition effects.

1. Preview the “button_start.paf” animation.

• Open the “button_start.paf” file located in the Tutorial 3
folder.

Play the animation to get an idea of what it looks like
before you start changing the effects. 

A blue-green glow appears around a button. After a few sec-
onds the glow disappears and the word “Extensis” appears.

Note: The glow is actually blue, but appears blue-green
when viewed around a green button and against a yellow
background. Since the visible effect is blue-green, we’ll be
referring to it that way.

Tip

Don’t forget that PhotoAnimator
provides multiple levels of Undo.
Simply press Command+Z
(Macintosh) or Control+Z
(Windows) as many times as nec-
essary to “wind back” your actions.  

You can Redo an undo operation
with Command+Y (Macintosh) or
Control+Y (Windows).

Tutorial 3: Working with Transitions and Gradient Masks
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This PhotoAnimator File (.paf) contains seven laye rs. All of
the laye rs are set up with cells, i m age s , and effects alre a dy in
place so that you can start right in wo rking with transitions. 

There are three of the layers in the Layers Pane that contain
the word “Transition” (Glow Transition, Button Transition,
and Dissolve Transition). Each of these layers already con-
tain the blank cells that you will use to cre ate the tra n s i t i o n
e ffects. 

Transition cell placement: A transition cell will affect the
content cell directly above it. Notice in this sample file that
we have placed each transition layer directly below the con-
tent layer that the transition will be applied to.

2. Begin by creating a transition between the Glow and
Background layers.

• Select the Glow Transition layer in the Layers Pane, then
click any frame in the first cell of the Glow Transition
layer in the Filmstrip pane.

Note: You don’t need to select a layer in the Layers Pane in
order to select a cell in that layer in the Filmstrip Pane, but
doing so makes it easier to locate the right Filmstrip layer.

• Select Effect > Transition > Barn Door from the
menubar.

• Select the following Barn Door Settings:

Accumulation: Intersection
Orientation: Vertical

Direction: Outward
Mode: None to All

• When you have completed the settings, click “OK.”
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Preview the animation.

Notice that the blue-green glow appears to grow around the
button shape in a vertical progression over the first eight
frames of the animation. 

3. Now you’ll make the glow disappear out of view using a
slight variation of the Barn Door transition.

• Click on any frame in the second cell on the Glow
Transition layer.

• Select Effect > Transition > Barn Door from the
menubar.

• Select the following Barn Door Settings:

Accumulation: Intersection
Orientation: Horizontal

Direction: Inward
Mode: None to All

• When you finish with the settings, click “OK.”

Preview the animation again. 

Fi rst the bl u e - green glow transitions into full view under
the direction of the ve rtical Barn Door wipe, then disap-
p e a rs. It next ap p e a rs hori zo n t a l ly, t ransitioning into full
v i ew under the direction of the hori zontal Barn Door wipe,
then disap p e a rs. 

4. Next you’ll create a transition so that the button fades into
view after being hidden at the start of the animation.

• Select the Button Transition layer in the Layers Pane.

Since there is only one cell in this layer, the cell is automati -
cally selected when you select the layer.

• Once again select Effect > Transition > Barn Door from
the menubar.

• Select the following Barn Door Settings:

Accumulation: Intersection
Orientation: Horizontal

Direction: Outward
Mode: None to All

• When you have completed the settings, click “OK.”

Preview the animation once again

This time the button fades into view horizontally while the
blue glow appears around the button for several frames and
then disappears. 
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5. For our last Web Button animation effect you will use a
Gradient Mask transition.

• Select the Dissolve Transition layer in the Layers Pane.

• Click on any frame in the second cell of the Dissolve
Transition Filmstrip layer (the first cell will not have an
effect applied to it and will act as a place-holder).

• Select Effect > Transition > Gradient Mask. 

Click on the Open file button in the Gradient Mask
Settings dialog box and select “dissolve.psd” from the
Tutorial 3 folder.

This places a texture in the second cell of the Dissolve
Transition layer that you will use as a gradient mask.

• Select the following Gradient Mask Settings:

Accumulation: Intersection
Direction: Black to White

Mode: None to All
Edge Levels: 0

You can set the Edge levels value to 0 by either entering the
number zero in the levels field or by dragging the Edge slid-
er to the far left. If you are wondering what Levels does,
don’t worry we’ll talk about Levels soon. 

• Click “OK.”

Preview the animation.

With our new settings, after the Button and Glow
Transitions perform their respective effects, the Button stays
fully visible and the word “Extensis” dissolves into view,
the result of using the Gradient Mask. 

As you can see, the Gradient Mask effect is more sophisti-
cated than the simple Barn Door transition. This Dissolve
effect is just one of the infinite types of transitions that the

Tip

The Player always starts an anima-
tion with the currently selected
frame. You can of course start the
animation at the first frame by
dragging the Player slider all the
way to the left. Another way is to
press the Home key.

The Home key takes you to the
first frame in the selected layer.
The End key takes you to the end
of the animation in the current
layer (even if the frame is empty).
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Gradient Mask feature is capable of making. Let’s look at
how Gradient Mask transitions work.

Gradient Mask Transitions: Gradient Mask effects use an
image as a mask to create the effect. As mentioned, this
mask can be a GIF (.gif) or a Photoshop format (.psd) file.
The Photoshop file can be an RGB, Grayscale, Indexed, or
Duotone image, but you cannot use Photoshop files that are
in LAB or CMYK color mode. Mask files do not need to be
the same size as the animation.

PhotoAnimator’s Gradient Mask Transition effect uses the
brightness values of the pixels in the mask file to create its
effect. Although you can use RGB, Duotone, or Indexed
color files as masks, for optimal results it is best to stick
with Grayscale images because PhotoAnimator will actually
convert other color formats to Grayscale anyway.

• Double-click any frame in the second cell of the Dissolve
Transition layer.

Recall from Tutorial 1 that once a cell has had an Effect
applied to it, double-clicking any frame in the cell automati-
cally opens the Effect Settings dialog box for that effect. In
this case, the Gradient Mask Settings dialog will open, since
that was the Effect last applied to this cell.

• In the Gradient Mask Settings dialog box, drag the Edge
slider to the right until the Levels field reads 130. 

The Levels control in the Gradient Mask Settings dialog
controls the transition “fuzziness.” Transitions created with
the Gradient Mask feature can look very different depending
on the Levels setting.
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• Click “Apply.”

(Recall that the Apply button only temporarily applies the
parameters in a given settings dialog box, allowing you to
Preview different settings before committing to them.) 

• Move the Gradient Mask Settings dialog so that you can
see the Preview Pane and the Gradient Mask Settings
dialog at the same time.

• Move the Player slider in the Settings dialog (its located
above the Revert and Apply buttons) back and forth and
observe the change in the animation Preview Pane.

If you look carefully, you’ll see that the dissolve effect has
been blurred by the new Levels setting of 130. 

If you move the Edge slider back to the far left (0) and pre-
view the animation again, you will see that the Edge Effect
is very pixelated—which is probably more appropriate for
this dissolve effect than the 130 Level you just looked at. 

So you can see that with the Gradient Mask Effect you can
c re ate a wide ra n ge of transition effects with any given mask
fi l e, c re ating an unlimited number of possibilities. In the nex t
exe rcise you will examine another file to see a few more of
the many cre at ive opportunities ava i l able with this unique
e ffe c t .

Tip

PhotoAnimator allows you to have
multiple files open at the same
time. This can be quite handy for
comparing effects. 

For example, you might set differ-
ent effect values for the same cell
in each of two otherwise identical
PhotoAnimator (.paf) files. You’d
put each animation Player in Loop
mode, and Play back both anima-
tions. Then just sit back and watch
the two playing side-by-side!
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Complex Animations with Gradient Masks—The Aperture
Animation

In this exe rcise you will look at a file with lots of Gra d i e n t
Transitions to get an idea of the cre at ive possibilities.

1. Examine the Aperture.paf animation.

• Open the “aperture.paf” file located in the Tutorial 3
folder.

Verify that the Loop button in the Preview Pane is
pressed so that the animation will play continuously.

Play  the animation. 

An aperture opens up to reveal a sort of radial explosion
effect, and then the aperture closes again. 

Notice that there are numerous invisible layers (layers with
their eye icon turned off) in the Layers Pane. This file was
created to show you a variety of Gradient Mask transitions.
You will hide and reveal different layers so that you can bet-
ter view these different transition effects. 

2. Hide the Aperture layer and examine the effect.

In the Layers Pane, hide the Aperture layer by clicking
on its eye icon (the eye should disappear indicating that
the layer is hidden).
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All of the layers are actually Gradient Masks except the
Aperture, RED and YELLOW layers. The RED and YEL-
LOW layers are filled with solid colors (Effect > Image >
Solid Color). Using solid colors as the background for a
Gradient Mask is a often a great way to set off the effect.

Notice that only four layers are currently visible: the “YEL-
LOW,” “Diagonal 1,” “Concentric,” and “RED” layers.

Preview the animation again, and notice the combined
effects of the “Diagonal 1” and “Concentric” Gradient
Mask layers on the “YELLOW” and the “RED” layers.

Hide the “Concentric” layer and then Preview the
animation again. 

Now hide the “Diagonal 1” layer and  turn the
“Concentric” layer back on. 

Preview the animation again. 

As you can see, the effects of these Gradient Mask layers
are very different. Take a moment now and turn on and off
various Gradient Mask layers and observe the results by pre-
viewing the animation. Try different combinations. After a
while you will begin to appreciate the incredible range of
possibilities with Gradient Mask transitions. 
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4. Now let’s look at a few of the mask files used to create
some of these Gradient Masks transitions.

First, unhide the “Twist 1” layer.

• Next, double-click on any frame in the second cell of the
Twist1 Filmstrip layer to open up the Gradient Mask
Settings dialog.

The Preview window in the Gradient Mask Settings dialog
shows the file used as the mask for this layer. This mask,
like most of the mask files in this example animation file,
was created in Photoshop using Filter Factory filters (most
of these filters are available for free on the Web). 

• Zoom in on the mask by clicking on the Plus (+) sign in
the Preview window of the Gradient Mask Settings
dialog.

• Roll your mouse cursor over this Preview window.
When the cursor changes to the hand icon, click and
drag to observe the detail of the mask. 

Notice that the mask has a broad range of gray values. In
general, the more gray values there are in a mask, the more
versatile the mask is. This is because the Gradient Mask
Transition effect uses the brightness values of each pixel to
create the transition effect over time. A mask with a large
variety of gray values in it gives the Gradient Mask
Transition more options. 
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Tips for Creating Masks Suitable for the Gradient Mask
Transition Effect

While you can generate a mask in any program that will export to
GIF or PSD format, for this exercise we will assume that you are
working in Photoshop. 

• Launch Photoshop and open a new file.

You generally want to start with a file size that is the same
or approximately the same as the animation that you will
use the mask in. You will also want to select RGB mode,
since many of Photoshop’s filters and features aren’t avail-
able in Grayscale mode.

• Press the letter “D” on your keyboard to ensure that the
foreground and background colors are set to black and
white respectively.

• Select a filter or line art to use as a base for the mask,
then add your own special effects.

A great place to start is with the Filter > Noise > Add Noise
(with the Monochrome setting on) filter, or Filter > Render
> Difference Clouds filter. These filters create random tex-
tures that you can use as starting points for your masks. You
can also start with any line art or patterns that you may
have. Simply convert the line art or patterns to gray values
with the Image > Adjust > Desaturate feature.

Once you have a basic foundation, try any variety of filters.
Our advice is for you to go wild. Just about anything will
work. However, some of the more simple effects might gen-
erate more practical results. For example , the mask used to
generate the dissolving text effect in the earlier example was
created with the Add Noise and Blur More filters. 

Another way to go is to apply a basic black to white gra-
dient. Try diagonal gradients or radial gradients. If you have
a solid line art shape like an ellipse, try applying Gaussian
Blur with a high setting to create in essence a custom
gradient.

PhotoAnimator’s Transition effects offer a wide range of
possibilities for animation. The potential variety offered
with the Gradient Mask transition effect is endless.
Especially since you can combine multiple Gradient Masks,
not to mention all of the other effects found in the Effects
menu in PhotoAnimator. You are limited only by your imag-
ination. Have fun!
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PhotoAnimator allows you to nest animations within a cell and
then apply effects to them much like you would to any other cell.
In this tutorial you will quickly create and use nested sub-anima-
tions.

Nested Sub-Animations—The Hectic Animation

1. Preview the “hectic_final.paf” animation.

• Open the “hectic_final.paf” file located in the Tutorial 4
folder.

Play the animation several times to get an idea of the
different animations that are a part of it.

Notice that this animation consists of five layers: “Run Left
(Nested),” “Hectic? Take a Break!,” “Barn Door Transition,”
“Run Right (Nested)” and “Background.” The two layers
that are labeled with (Nested) contain animated animations,
or what PhotoAnimator calls Nested Sub-Animations.

• Click “Run Right (Nested)” layer in the Layers Pane.

This layer contains one 14-frame cell. Notice that when you
select this cell the “Enter” button below the Filmstrip Pane
becomes active.

Click the Enter button.

Tip

Don’t forget that PhotoAnimator
provides multiple levels of Undo.
Simply press Command+Z
(Macintosh) or Control+Z
(Windows) as many times as nec-
essary to “wind back” your actions.  

You can Redo an undo operation
with Command+Y (Macintosh) or
Control+Y (Windows).

Tutorial 4: Working with Nested Sub-Animations
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When you click on the Enter button PhotoAnimator takes
you into a Nested Sub-Animation work area. The Nested
Sub-Animation Window behaves exactly like it does with
regular animations in PhotoAnimator: You can work with
layers on the Layer Pane, preview the Nested Sub-
Animation in the Preview Pane, and work with frames and
cells in the Filmstrip Pane, just as you can with a normal
animation. 

Preview the Nested animation.

This nested animation consists of a simple loop of a stylized
running stick figure. Notice that the stick figure is running
in a stationary position. As you will soon see, the advantage
of using a Sub-Animation is that you can apply movement
to it externally. In other words, you can move, rotate, resize
or otherwise apply any of PhotoAnimator’s effects to a nest-
ed animation. This means that you can easily make adjust-
ments to the movements of the sub-animation. 

More importantly, your nested sub-animations can have the
same characteristics as normal layers. This means that your
nested animations can move wherever you want them to and
you don’t have to worry about anti-aliasing to other imagery
in the animation. PhotoAnimator takes care of that for you
when you export.

Click the Leave button, then close the
“hectic_final.paf” file without saving changes.
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2. Open the “hectic_start.paf” file located in the Tutorial 4
folder.

• Select the “Run Left (Nested)” layer and create a new
cell on this layer. Resize the cell to 32 frames.

• Select Effect > Basic > Sub-Animation. . . from the
menubar.

• Select Loop from the Frame Action pop-up menu, then
click “OK.”

Click the Enter button at the bottom of the Filmstrip
Pane to open the Nested Sub-Animation work area. 

Click on the empty cell on the Filmstrip Pane, then click
the Trash icon, or press the Delete key on your key-
board.

You’re going to import a file with multiple graphics, so you
first needed to delete the existing cell.

Click the Import button.

• Locate the “run_left.psd” file in the Tutorial 4 folder,
then click “Open.”

The Photoshop Import Options dialog box will be displayed.

• In the Photoshop Import Options dialog box, set the
Layer Wrapping Options to “Horizontal Inline (frames)”
and set Layer Import Direction  to “Top to Bottom.”

• Click “Import” to import the image file.

This imports a seven-layer Photoshop (.psd) document into
PhotoAnimator. With the settings you specified in the
Import Options dialog, each  Photoshop layer was placed in
the animation file as a separate single-frame cell. We now
have a Nested Sub-Animation that contains seven cells.

Tip

To Import an image file, press
Command+I (Macintosh) or
Control+I (Windows) .
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Click “Leave” to return to the regular animation
work area.

• Hide all the of the layers in the animation except for the
Run Left (Nested) layer.

Now preview the animation. 

The little character runs in place on the left side of the
screen.

• To help you see the little character more easily, unhide
the Background layer.

Preview the animation again.

Now it’s time to experience the fundamental advantage of a
nested animation. You will make this little guy run across the
entire animation instead of just in place.

4. M a ke the Nested Sub-Animation move across the fra m e.

• Double-click on any frame in the cell on the Run Left
(Nested) layer in the Filmstrip Pane.

This opens the Nested Sub-Animation Settings dialog box. 

• In the Nested Sub-Animations Settings, click the “Move
To” check box (it should now display a checkmark). 

• In the “Location” field, drag  the small white rectangle
of the Image Proxy to the top-right corner of the grid.
Position it so that it is off-screen on the top-most right-
hand edge of the grid. (See screenshot at left.)

• In the “Move To” field, drag the small white rectangle of
the Image Proxy to the top-left corner of the grid.
Position it so that it is off-screen on the top-most left-
hand edge of the grid. (See screenshot at left.)

• Click “OK” to apply the settings and close the dialog.

Once again, preview the animation. 

Notice that the little character runs across the entire animation
from left to right. PhotoAnimator has taken the stationary
nested animation and moved it over the banner making it
appear as if the running character is running from one place to
the other!

Tip

To instantly hide all layers but one,
press the Option (Macintosh) or
ALT (Windows) key while clicking
on the eye icon of the layer you
wish to keep visible. Option-click -
ing (Macintosh) or ALT-clicking
(Windows) again will unhide all the
layers.
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Turn on the other layers and preview the entire
animation.

You can non-destructively manipulate the nested animations
as much as you want before you export the animation. Photo-
Animator also allows you to apply effects to nested anima-
tions and nested animations can have multiple layers just like
a normal animation. 

You will discover that you can create awesome animation
effects very easily using Nested Sub-Animations—animations
that would take you hours to create with a traditional gif ani-
mation tool. 

In the final tutorial (Tutorial 5) you will learn about Photo-
Animator’s powerful Export options. 



PhotoAnimator has three export options. You can export as a GIF
animation, as a Photoshop file, and as a PhotoAnimator file or
template. You will look at all three options in this tutorial, but the
lion’s share of this tutorial will deal with exporting a PhotoAni-
mator file to GIF animation. 

Exporting to a GIF Animation—The Banner Ad Animation

When you export to Animated GIF from PhotoAnimator you are
converting the animation from millions of colors (24-bit) to any-
where from 256 to 4 colors (8, 7, 6, 5, 4, 3 and/or 2-bit). Also, all
of the layers are merged down to a single layer for each frame.

In this first example, you will open a sample banner ad and export
it as a GIF animation. Web banner ads need to download quickly
over the Internet, so the the objective is to get this banner ad
down to the smallest file size possible without sacrificing the
visual quality of the images in the animation.

1. Specify Export Format

• Open the “EPA_ad.paf” file located in the Tutorial 5
folder on the Extensis CD.

Don’t worry about previewing the animation, you will do
that several times within the Export dialog box. 

• Select File > Export. . . from the menubar.

• From the Format pop-up, select “ Animated GIF.”
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Tutorial 5: Export i n g



2. Specify Dithering

• Examine the Dithering pop-up menu and notice that
there are three options: None, Diffusion, and Pattern. 

In general the “None” option provides the best GIF com-
pression. The Diffusion option can be a better choice for
visual quality in some cases. Pattern is an another alternative
to instead of the Diffusion option. 

• For this example, select Dithering: None.

3. Specify Color

• Examine the Color Set pop-up menu. 

PhotoAnimator provides a wide range of palettes, including
the Netscape palette (also known as the “Web palette”) as
well as several Macintosh and Windows palettes. Most ani-
mators will opt for the Adaptive palette which creates an
adaptive palette from the available colors in the layered 24-
bit version of the animation. In most cases the adaptive
palette will result in an animation that looks as close to the
24-bit original version as possible.

• Select Color Set: Adaptive

Note: As you create content that you will animate in
PhotoAnimator, we recommend choosing colors from the
Netscape palette whenever possible. This will help maintain
the visual integrity of the animation when it is viewed on
8-bit systems. Just be aware that, though the Netscape
palette is often recommended, selecting this palette on
export often results in unnecessary visual quality loss in the
animation when the animation is not predominantly com-
posed of colors from the Netscape palette, such as photo-
graphic images. 

4. Specify Maximum Colors

• Examine the Maximum Colors pop-up menu.  Note that
you have the option of choosing from 256, 128, 64, 32, 16,
8 and 4 colors. 

PhotoAnimator will generate a palette for the animation that
contains no more colors than the number you have selected.
For example, if you choose 64, PhotoAnimator will create a
palette for the animation that contains 64 colors. PhotoAni-
mator will do this while attempting to keep as many colors
from the original 24-bit color version as possible.

However, PhotoAnimator always performs certain optimiza-
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tions for you automatically. For instance, if you choose 64
colors and the image you are exporting actually contains
fewer than 64 colors, PhotoAnimator automatically removes
unused colors from the color palette to ensure that you will
end up with the smallest possible file size.

Note that the Maximum Colors pop-up menu is only avail-
able when Adaptive palette is the selected Color Set pop-up
menu. 

• For now, select Maximum Colors: 256

5. Specify Optimization

Below the Maximum Colors pop-up menu is the Interframe
Transparency Optimization check box. 

If you check this option, PhotoAnimator will optimize the
animation by building transparency into the animation’s
frame whenever possible. Web browsers display GIF anima-
tions by displaying one frame over another. If parts of one
frame contain the same imagery as in the previous frame,
you can reduce the file size of the animation by making
these redundant portions of the frame transparent. 

To demonstrate how valuable this can be, leave this option
off for now.

• For now, de-select (uncheck) Interframe Transparency
Optimization.

Note: Depending on the content of your animations, some-
times this option can actually make the file size larger.
However, PhotoAnimator can calculate the file size of your
animation based on the Export options you specify. You will
see that it is quite easy to compare file sizes as you make
different choices to end up with the smallest file size.

6. Examine Loop options 

With these options you can specify whether you want the
animation to loop indefinitely or not. 

• Select Loop: Forever.

The remaining features in the Animated GIF Export Options
dialog box allow you to preview the results of the options
you have selected before you export. 

This is a very valuable aspect of PhotoAnimator. It means
that you can experiment with various options and preview
them before you actually export to GIF.
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Before you move on, notice that there are two lines that read
“File Size” and “Download Time.” These two lines both
have the word “recalculate” next to them in parenthesis.
This will be explained in a moment.

7. Test your animation with the options you specified

• Click the Calculate/Preview button and watch carefully.

After a few seconds, the Calculate/Preview button will
become grayed out. Notice that there are now values dis-
played by the  “File Size” and “Download time”. 

• Verify that the display indicates the following values:

File Size = 24,928 bytes
Download time = 12 seconds. 

The “File Size” indicator tells you how large the file will be,
in bytes, if you were to export the animation with the cur-
rent settings. The currently displayed values tell you that if
you were to export this banner ad with dithering set to none,
using an adaptive palette with 256 colors, and no interframe
transparency optimization, the animation would have a file
size of 24,928 bytes, which is about 24.9 Kilobytes.

The “Download time” indicator is related to the Connection
Speed pop-up menu, which displays 28.8 Kbps (Kilobytes
per second) by default. Our “Download time” readout indi-
cates that it will take approximately 12 seconds to download
this animation with a file size of 24.9K. If you select a dif-
ferent download speed from the Connection Speed pop-up
menu, this Download time will change to reflect how long it
would take to download the animation at its current file size
on the selected connection speed.

The Download time and Connection Speed options in the
Animated GIF Export Options dialog box allow you to gen-
erate animations that are optimal for your target connection
rate. In other words, if you think that the majority of your
site’s visitors will be connected to the Internet with
14.4Kbps modems, you can use these features to help make
sure that your animations will work within any parameters
that you have set for the site.

Note: The Preview will play back the animation at the
Frame Rate speed you choose from the Animation > Frame
Rate. . . menu before you enter the Export Options Dialog
box. In other words, the playback speed of an animation has
nothing to do with how long an animation takes to down-
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load to the viewer’s page. It takes a certain amount of time
for an animation to download before it will begin its seam-
less playback in the viewer’s browser, and that speed is what
the Download Time calculation is showing you.

Twelve seconds is a long time to have to wait for this banner
ad, especially since banner ads are usually not the only thing
on a Web page. You will need to make this animation much
smaller. Fortunately, with PhotoAnimator this is easy to do.

8. Minimize download time

• Select Interframe Transparency Optimization by click-
ing the box (checkmark in it). 

Notice that the Calculate/Preview button becomes active and
the “File Size” and Download time” options now display
”(recalculate).” This indicates that some parameter used in
the previous calculation has been changed and the values
must be recalculated.

• Click the Calculate/Preview button.

The File Size indicator now shows that the file size has
dropped to 21,643 bytes (21.6K) and the Download time is
now approximately 11 seconds. You have chopped over 3K
off the animation’s file size and cut the download time by 1
second. Not bad, but you’re just getting warmed up!

• Select Maximum Colors: 16, then click the
Calculate/Preview button again. 

Now File Size indicates that the animation would only be
12,264 bytes and the Download time would take a mere 6
seconds to travel over the Internet. In other words, by reduc-
ing the color palette to 16 colors, and turning Interframe
Transparency Optimization on, you can cut the file size (and
thereby the download time) of the animation in half.

It is nice that you’ve been able to make the animation’s file
size so small, but you don’t want to present a poor quality
animation. You’ve just thrown out 240 colors— will the ani-
mation still be worth looking at? 



9. Preview the animation to verify its visual quality, then
Export the animation

Press the Loop button in the animation Player in the
Export Options dialog, then Preview the animation. 

The Preview window in the Export Options dialog will
show you how the animation will look at the calculated set-
tings. Note that the Preview is not available until a down-
load time has been  calculated.

If you zoom in and study parts of the animation you’ll see
that the animation looks very similar to the original 24-bit
version. But let’s confirm this. 

• Select Maximum Colors: 256 while the animation
Preview is still running.

Notice that you do not have to click on the Calculate/
Preview button again. PhotoAnimator remembers the set-
tings of the previous calculations you chose so that you can
switch back and forth between 256 and 16 colors while the
preview is playing to compare the differences.

Since you have verified that our settings are satisfactory (16
color adaptive palette with no dithering and Interframe
Transparency Optimization turned on), you can now to
export the animation. 

Important: This part of the tutorial is extremely complicated,
so pay very close attention. Even seasoned professionals get
lost when trying to perform this step. Now then...

• Click the Export button.

In all seriousness, that’s all there is to it. PhotoAnimator
takes care of everything for you, automatically generating
an optimized GIF animation from your 24-bit layered
PhotoAnimator document. 
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To fully appreciate this, look carefully at the image below.

This image shows what the exported animation looks like
frame-by-frame. The light and medium gray blocks repre-
sent the portions of the animation optimized with interframe
transparency. In other words, the light and medium gray
portions represent transparency.

Another important thing to notice is that the animation
exported only 14 frames. If you look at the filmstrip layers
in the “EPA_ad.paf” file you will see that some layers are as
many as 45 frames long. However, the majority of these
frames are static duplicates. That is, 32 frames are each
duplicates of one another. The duplicates are there so that
the animation will pause on the last frame long enough for
the viewer to read the text on the banner ad, before the ani-
mation loops back to the beginning and starts over again.

PhotoAnimator recognized the duplicate frames and com-
piled them all into one frame by lengthening the display
time of that frame. While the first 13 frames of the anima-
tion each display for 7/100ths of a second, the last frame of
the animation is displayed much longer: just over two sec-
onds. Including those redundant frames in the animation
would have added to the animation’s file size unnecessarily.
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Tip

You can set the rate of an anima-
tion with the Frame Rate command
located in the Animation menu, or
by pressing Command+G (Mac-
intosh) or Control+G (Windows).



Tips for Keeping GIF Animation File Sizes Down

While PhotoAnimator automates the process of optimizing an ani-
mation’s file size, it can only do so much with what it has been
given. It is very easy to create prohibitively large GIF animations
with PhotoAnimator’s powerful animation features. Consider
these guidelines for keeping your animation files manageable.

1. Keep transitions to as few frames as possible.

For instance, if you are moving a logo across a banner ad and
you have set the motion to occur across 15 frames, could you
achieve a believable effect by using only 10 or even 5 frames?
If your file size is not as low as you want it to be, try resizing
your cells to fewer frames, then compare the difference.

2. Use the Fade transition sparingly.

In order to achieve it’s effect, the Fade transition effect must
add colors to your animation which will make it more difficult
to export your animation at lower bit depths. A lot of the time,
using one of the Wipe or Barn Door transitions will create a
similar effect, but with a much smaller hit on file size.

3. Try to confine your animation to a small palette.

Heavy use of colorful photographic or 3D images can make it
difficult to export your animation at lower bit depths without
sacrificing image quality.

4. Use the Dithering: None option whenever possible.

The GIF format employs LZW compression, which works
best with contiguous strings of same-color pixels. So the more
dithering in an image, the more difficult it will be for the GIF
format to compress the animation.
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Exporting to Photoshop Format

PhotoAnimator also allows you to export to a layered Photoshop
file. The main benefit to this export option is that it allows you to
export frames created with PhotoAnimator for editing back in
Photoshop. Since PhotoAnimator also imports layered Photoshop
files, you can export out a PhotoAnimator file out as a layered
Photoshop file and then re-import the results back into
PhotoAnimator. This makes PhotoAnimator an excellent anima-
tion companion to Adobe Photoshop. 

And what is really cool about this Photoshop support is that
PhotoAnimator understands all of Photoshop’s transparency and
layer information. (Example: If you create some text on a layer in
Photoshop, and then create a 50% opaque drop shadow of the text
on a separate layer, PhotoAnimator will bring in both layers and
retain the transparency of the drop shadow. Woo-hoo!)

The Photoshop Export Options dialog box contains only two
options, both of which control the Frame Order of the exported
file. You can choose to have the frames ordered from Top to
Bottom (frame 1 of your PhotoAnimator document will translate
to the top layer in the layered Photoshop file, and so on) or you
can elect to have the frames ordered from Bottom to Top (the last
frame of your PhotoAnimator document will translate to the top
layer in the layered Photoshop file, and so on). 

Note that, unlike exporting to the GIF format, all redundant
PhotoAnimator frames are exported as individual Photoshop lay-
ers. For example, our 45 frame example animation will export to a
45 layer Photoshop file.

67



Exporting to PhotoAnimator File or Template

PhotoAnimator’s final export option is to a PhotoAnimator file
(PAF) or template (PAT). The advantage of exporting to a
PhotoAnimator file is that you can then import the file back into
PhotoAnimator as a Nested Sub-Animation. 

Exporting to a PhotoAnimator Template allows you to construct a
layered document in PhotoAnimator that you can use over and
over again by simply swapping in different images. For example,
you might make a template for banner ads so that you can simply
swap in a different message or background and to generate any
number of ads from the template.
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Cut Command+X Control+X
Copy Command+C Control+C
Paste Command+V Control+V
Select All Command+A Control+A
Undo Command+Z Control+Z
Redo Command+Y Control+Y
Import Command+I Control+I
Export Command+E Control+E

Frame Size Command+F Control+F
Frame Rate Command+G Control+G
New Layer Command+L Control+L
New Cell Command+K Control+K
Delete Cell Delete or Del Backspace or Delete
Duplicate Cell Option+Drag cell Alt+Drag cell
Extend Cell Option+Click on blank frame Alt+Click on blank frame
New Cell Shift+Click on blank frame Shift+Click on blank frame

Effect Settings (for currently applied effect) Command+T Control+T

Play/Stop Animation Spacebar Spacebar
Preview Zoom In Command+“+” Control+“+”
Preview Zoom Out Command+“-” Control+ “-”

Hide all layers except this one Option+Click eye icon Alt+Click eye icon
Show all layers including this one Option+Click eye icon Alt+Click eye icon

Select (relative to currently selected)
First Frame in layer Home Home
Last Frame in layer End End
Frame Right à à
Frame Left ß ß
Cell Right Shift+à Shift+à
Cell Left Shift+ß Shift+ß
Layer Up á á
Layer Down â â

New Animation File Command+N Control+N
Open Animation File Command+O Control+O
Save Animation File Command+S Control+S
Close Animation File Command+W Control+F4 or Control+W
Quit PhotoAnimator Command+Q Alt+F4 or Control+Q

Appendix A: Keyboard Shortcuts

Function Performed Macintosh Windows
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We’d like to know what you think we could do to make Extensis
P h o t o A n i m ator better. So if you have an idea for a new product fe at u re,
a modifi c ation to an existing one, or anything else you can think of that
will help us make this product better—we ’d like to hear from yo u .

To help make Extensis PhotoAnimator better, please. . .

1. Print your name, address, and phone number below and sign your 
name.

2. Describe your idea or comment.
3. Tear this page out and mail or fax this sheet to Extensis.

I understand that no compensation will be awarded for my suggestion.

My suggestion is…

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Name

Street Address

City State           Country                              Zip/Postal Code

Daytime Phone Daytime Fax

Thanks for your suggestions! Hopefully you’ll see your ideas in future
versions of this or other Extensis products.

Suggestion
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